Ant Design of React

antd 是基于 Ant Design 设计体系的 React UI 组件库,主要用于研发企业级中后台产品。

+

✨ 特性#

  • 🌈 提炼自企业级中后台产品的交互语言和视觉风格。

  • 📦 开箱即用的高质量 React 组件。

  • 🛡 使用 TypeScript 开发,提供完整的类型定义文件。

  • ⚙️ 全链路开发和设计工具体系。

  • 🌍 数十个国际化语言支持。

  • 🎨 深入每个细节的主题定制能力。

兼容环境#

IE / Edge
IE / Edge
Firefox
Firefox
Chrome
Chrome
Safari
Safari
Opera
Opera
Electron
Electron
IE11, Edgelast 2 versionslast 2 versionslast 2 versionslast 2 versionslast 2 versions

对于 IE 系列浏览器,需要提供相应的 Polyfill 支持,建议使用 @babel/preset-env 来解决浏览器兼容问题。如果你在使用 umi,可以直接使用 targets 配置。

antd@2.0 之后不再支持 IE8。 antd@4.0 之后不再支持 React 15 和 IE9/10。

版本#

  • 稳定版:npm package

你可以订阅:https://github.com/ant-design/ant-design/releases.atomhttps://app.releasly.co/sites/ant-design/ant-design 来获得版本发布的通知。

安装#

使用 npm 或 yarn 安装#

我们推荐使用 npm 或 yarn 的方式进行开发,不仅可在开发环境轻松调试,也可放心地在生产环境打包部署使用,享受整个生态圈和工具链带来的诸多好处。

$ npm install antd --save
$ yarn add antd

如果你的网络环境不佳,推荐使用 cnpm

浏览器引入#

在浏览器中使用 scriptlink 标签直接引入文件,并使用全局变量 antd

我们在 npm 发布包内的 antd/dist 目录下提供了 antd.js antd.css 以及 antd.min.js antd.min.css。你也可以通过 CDNJSUNPKG 进行下载。

强烈不推荐使用已构建文件,这样无法按需加载,而且难以获得底层依赖模块的 bug 快速修复支持。

注意:antd.jsantd.min.js 依赖 react/react-dom/moment,请确保提前引入这些文件。

示例#

import { DatePicker } from 'antd';

ReactDOM.render(<DatePicker />, mountNode);

引入样式:

import 'antd/dist/antd.css'; // or 'antd/dist/antd.less'

按需加载#

antd 的 JS 代码默认支持基于 ES modules 的 tree shaking。

TypeScript#

antd 使用 TypeScript 进行书写并提供了完整的定义文件。(不要引用 @types/antd)。

链接#

谁在使用#

如果你的公司和产品使用了 Ant Design,欢迎到 这里 留言。

如何贡献#

在任何形式的参与前,请先阅读 贡献者文档。如果你希望参与贡献,欢迎 Pull Request,或给我们 报告 Bug

强烈推荐阅读 《提问的智慧》《如何向开源社区提问题》《如何有效地报告 Bug》《如何向开源项目提交无法解答的问题》,更好的问题更容易获得帮助。

社区互助#

如果您在使用的过程中碰到问题,可以通过下面几个途径寻求帮助,同时我们也鼓励资深用户通过下面的途径给新人提供帮助。

通过 Stack Overflow 或者 Segment Fault 提问时,建议加上 antd 标签。

  1. Stack Overflow(English)

  2. Segment Fault(中文)

  3. Gitter(English)

  4. Join the chat at https://gitter.im/ant-design/ant-design(中文)

快速上手